Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 28627 Accepted Submission(s): 19653

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this: N=a[1]+a[2]+a[3]+...+a[m]; a[i]>0,1<=m<=N; My question is how many different equations you can find for a given N. For example, assume N is 4, we can find: 4 = 4; 4 = 3 + 1; 4 = 2 + 2; 4 = 2 + 1 + 1; 4 = 1 + 1 + 1 + 1; so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20

Sample Output

5
42
627

Author

Ignatius.L

Recommend

Accepted Code

//母函数
package cn.edu.hdu.acm;

import java.util.Scanner;

public class Main1028 {

    public static void main(String[] args){

        Scanner sc = new Scanner(System.in);

        while(sc.hasNextInt()){
            int n = sc.nextInt();
            int[] s1 =  new int[300];
            int[] s2 =  new int[300];

            for(int i = 0; i <= n;i++){
                s1[i] = 1;//初始化第一个括号中的系数,s1[i]这里代表指数为i的项的系数。
                s2[i] = 0;
            }

            for(int i = 2;i <= n;i++){
                for(int j = 0; j <= n ;j++){
                    for(int k = 0; k + j <=n;k+=i){
                        s2[j+k] +=s1[j];
                    }
                }
                for(int j = 0;j<=n ;j++){
                    s1[j] = s2[j];
                    s2[j] = 0;
                }
            }
            System.out.println(s1[n]);
        }
    }
}

results matching ""

    No results matching ""